]> Pileus Git - ~andy/sunrise/blob - net-analyzer/tcping/tcping-1.3.5.ebuild
games-misc/limbs-off: Version bump for games-misc/limbs-off-alpha
[~andy/sunrise] / net-analyzer / tcping / tcping-1.3.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit toolchain-funcs
8
9 DESCRIPTION="Ping implementation that uses the TCP protocol"
10 HOMEPAGE="http://www.linuxco.de/tcping/tcping.html"
11 SRC_URI="http://www.linuxco.de/tcping/${P}.tar.gz"
12
13 LICENSE="LGPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 src_prepare() {
19         sed -i -e '/^CC/d' \
20                 -e 's/$(CCFLAGS)/$(CFLAGS) $(LDFLAGS)/' \
21                 Makefile || die "sed Makefile failed"
22 }
23
24 src_compile() {
25         tc-export CC
26         default
27 }
28
29 src_install() {
30         dobin tcping
31         dodoc README
32 }