]> Pileus Git - ~andy/sunrise/blob - net-analyzer/packetgarden/packetgarden-1.0.ebuild
7961c07286218c7f1b84dc960b9df7edbe296553
[~andy/sunrise] / net-analyzer / packetgarden / packetgarden-1.0.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils python
6
7 MY_P="${P/-/_}_all"
8
9 DESCRIPTION="captures information about how you use the internet and use it to grow a private world"
10 HOMEPAGE="http://www.packetgarden.com/"
11 SRC_URI="http://selectparks.net/~julian/pg/dists/${MY_P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND=""
19 RDEPEND="dev-python/dpkt
20         dev-python/imaging
21         dev-python/geoip-python
22         dev-python/pypcap
23         >=dev-python/soya-0.13_rc1
24         x11-libs/gksu"
25
26 S=${WORKDIR}/${MY_P}
27
28 pkg_setup() {
29         if ! built_with_use dev-python/soya openal ; then
30                 eerror "${PN} needs dev-python/soya built with openal USE flag enabled."
31                 die "dev-python/soya without openal"
32         fi
33 }
34
35 src_unpack() {
36         unpack ${A}
37         cd "${S}"
38         epatch "${FILESDIR}/${P}-launcher.patch"
39         epatch "${FILESDIR}/${P}-games-path.patch"
40 }
41
42 src_install() {
43         newbin stop_capture packetgarden-stop
44         dobin packetgarden
45         insinto /usr/share/${PN}
46         doins -r config data guide labels logs stats pg_*.py
47         dodoc README_LINUX.txt
48         keepdir /usr/share/${PN}/data/images/screenshots
49 }
50
51 pkg_postinst() {
52         python_mod_optimize "${ROOT}/usr/share/${PN}"
53         elog
54         elog "In order to get a good performance it is very recomended"
55         elog "to install dev-python/psyco"
56         elog
57 }
58
59 pkg_postrm() {
60         python_mod_cleanup "${ROOT}/usr/share/${PN}"
61 }