]> Pileus Git - ~andy/sunrise/blob - net-analyzer/packetgarden/packetgarden-1.0-r1.ebuild
f7249b4f6ce2e89c87720173f5d6152941d66801
[~andy/sunrise] / net-analyzer / packetgarden / packetgarden-1.0-r1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit base python
8
9 MY_P="${P/-/_}_all"
10
11 DESCRIPTION="captures information about how you use the internet and use it to grow a private world"
12 HOMEPAGE="http://selectparks.net/~julian/pg/"
13 SRC_URI="http://selectparks.net/~julian/pg/dists/${MY_P}.tar.gz -> ${MY_P}-${PVR}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~x86"
18 IUSE=""
19
20 DEPEND=""
21 RDEPEND="dev-python/dpkt
22         dev-python/imaging
23         dev-python/geoip-python
24         dev-python/pypcap
25         || ( >=dev-python/soya-0.13_rc1[openal] =dev-python/soya-0.14 )
26         x11-libs/gksu"
27
28 S=${WORKDIR}/trunk
29
30 PATCHES=( "${FILESDIR}/${P}-launcher.patch"
31         "${FILESDIR}/${P}-games-path.patch" )
32
33 src_install() {
34         newbin stop_capture packetgarden-stop || die
35         dobin packetgarden || die
36         insinto /usr/share/${PN}
37         doins -r config data guide labels logs stats pg_*.py || die
38         dodoc README_LINUX.txt || die
39         keepdir /usr/share/${PN}/data/images/screenshots
40 }
41
42 pkg_postinst() {
43         python_mod_optimize "${ROOT}/usr/share/${PN}"
44         elog
45         elog "In order to get a good performance it is very recomended"
46         elog "to install dev-python/psyco"
47         elog
48 }
49
50 pkg_postrm() {
51         python_mod_cleanup "${ROOT}/usr/share/${PN}"
52 }