]> Pileus Git - ~andy/sunrise/blob - net-analyzer/ncrack/ncrack-0.2_alpha.ebuild
184f5f91eede9c8060ee5e4c2c4baa9ea8edc197
[~andy/sunrise] / net-analyzer / ncrack / ncrack-0.2_alpha.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit base versionator
8
9 DESCRIPTION="a high-speed network authentication cracking tool"
10 HOMEPAGE="http://nmap.org/ncrack/"
11 MY_P="${PN}-$(get_version_component_range 1-2)ALPHA"
12 SRC_URI="http://nmap.org/${PN}/dist/${MY_P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="ssl"
18
19 RDEPEND="ssl? ( dev-libs/openssl )"
20 DEPEND="${RDEPEND}"
21
22 S=${WORKDIR}/${MY_P}
23
24 src_prepare() {
25         sed -i -e '/STRIP =/s:= .*:= echo:' Makefile.in || die
26 }
27
28 src_configure() {
29         econf --with-openssl=$(use ssl && echo yes || echo no)
30 }
31
32 DOCS=( CHANGELOG docs/{AUTHORS,TODO,{engine,mirror_pool,openssh-library}.txt} )