]> Pileus Git - ~andy/sunrise/blob - net-analyzer/ArpON/ArpON-1.90.ebuild
6774c1808145263add452acb87bb86c229f4eebc
[~andy/sunrise] / net-analyzer / ArpON / ArpON-1.90.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=1
6
7 DESCRIPTION="ArpON (Arp handler inspectiON) is a portable Arp handler."
8
9 HOMEPAGE="http://arpon.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/arpon/${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~sparc ~x86"
15 IUSE=""
16
17 DEPEND="dev-libs/libdnet
18         net-libs/libnet:1.1
19         net-libs/libpcap"
20
21 RDEPEND=${DEPEND}
22
23 src_compile() {
24         emake gentoo || die "emake Gentoo failed"
25 }
26
27 src_install() {
28         dosbin arpon  || die "arpon installation failed"
29         doman man8/arpon.8 || die "arpon man installation failed"
30         dodoc AUTHORS  CHANGELOG LICENSE  TODO || die
31         dohtml man8/html/*.html doc/*.png || die
32 }