]> Pileus Git - ~andy/sunrise/blob - media-video/stk11xx/stk11xx-2.1.0.ebuild
4cb005ee7dbddd2d688712edb437c0eeab833592
[~andy/sunrise] / media-video / stk11xx / stk11xx-2.1.0.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit linux-mod
8
9 DESCRIPTION="Driver for Syntek webcams"
10 HOMEPAGE="http://syntekdriver.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/syntekdriver/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 MODULE_NAMES="stk11xx(media/video:)"
19 BUILD_TARGETS="stk11xx.ko"
20 CONFIG_CHECK="VIDEO_DEV VIDEO_V4L1_COMPAT"
21
22 src_prepare() {
23         epatch "${FILESDIR}"/${PN}-v4l_compat_ioctl32.diff
24         BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S}"
25 }
26
27 src_install() {
28         linux-mod_src_install
29         dodoc README || die "dodoc failed"
30 }