]> Pileus Git - ~andy/sunrise/blob - media-video/sabbu/sabbu-0.3.0.ebuild
e2e971c39d662e536ce2e7dd69cb66474a03d4d7
[~andy/sunrise] / media-video / sabbu / sabbu-0.3.0.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Subtitle script creator/editor"
8 HOMEPAGE="http://www.sabbu.com/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE="ffmpeg nls oss"
15
16 RDEPEND="ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20051120 )
17         nls? ( sys-devel/gettext )
18         >=x11-libs/gtk+-2.6
19         media-libs/libsndfile"
20 DEPEND="${RDEPEND}
21         dev-util/pkgconfig"
22
23 src_unpack() {
24         unpack ${A}
25         cd "${S}"
26
27         epatch "${FILESDIR}/${P}-new-ffmpeg.patch"
28 }
29
30 src_compile() {
31         econf $(use_with ffmpeg) \
32                 $(use_enable nls) \
33                 $(use_with oss) \
34                 || die "econf failed"
35
36         emake || die "emake failed"
37 }
38
39 src_install() {
40         emake DESTDIR="${D}" install || die "emake install failed"
41         dodoc AUTHORS ChangeLog NEWS README
42 }