]> Pileus Git - ~andy/sunrise/blob - media-video/aegisub/aegisub-2.1.6_pre2939.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / media-video / aegisub / aegisub-2.1.6_pre2939.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 WX_GTK_VER="2.8"
7 inherit eutils wxwidgets
8
9 MY_P=${P/_pre/-dev-r}
10
11 DESCRIPTION="Advanced SSA/ASS subtitle editor"
12 HOMEPAGE="http://www.aegisub.net"
13 SRC_URI="http://www.mahou.org/~verm/aegisub/${MY_P}.tar.gz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="alsa debug +ffmpeg lua openal perl pulseaudio spell ruby"
19
20 RDEPEND="=x11-libs/wxGTK-2.8*[opengl]
21         media-libs/libass
22         media-libs/fontconfig
23         media-libs/freetype
24         virtual/glu
25
26         alsa? ( media-libs/alsa-lib )
27         pulseaudio? ( media-sound/pulseaudio )
28         openal? ( media-libs/openal )
29         ffmpeg? ( media-video/ffmpeg )
30
31         perl? ( dev-lang/perl )
32         ruby? ( dev-lang/ruby )
33         lua? ( dev-lang/lua )
34
35         spell? ( app-text/hunspell )"
36
37 DEPEND="${RDEPEND}
38         dev-util/pkgconfig
39         media-gfx/imagemagick
40         dev-libs/glib
41         sys-devel/gettext"
42
43 S=${WORKDIR}/${MY_P}
44
45 src_configure() {
46         econf $(use_with alsa) \
47         --without-portaudio \
48         $(use_with pulseaudio) \
49         $(use_with openal) \
50         $(use_with lua) \
51         $(use_with ruby) \
52         $(use_with perl) \
53         $(use_with ffmpeg) \
54         $(use_with spell hunspell) \
55         $(use_enable debug)
56 }
57
58 src_install() {
59         emake DESTDIR="${D}" install || die "emake install failed"
60         doicon "${FILESDIR}"/${PN}.png
61         make_desktop_entry "${PN}" "Aegisub" "${PN}" "AudioVideo;Video;"
62 }