]> Pileus Git - ~andy/sunrise/blob - media-tv/otrdecoder-bin/otrdecoder-bin-592.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / media-tv / otrdecoder-bin / otrdecoder-bin-592.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 DESCRIPTION="Decoder for onlinetvrecorder.com (German)"
8 HOMEPAGE="http://www.onlinetvrecorder.com/"
9 SRC_URI="amd64? ( http://www.onlinetvrecorder.com/downloads/${PN}-linux-Ubuntu_8.04.2-x86_64-0.4.613.tar.bz2 )
10         x86? ( http://www.onlinetvrecorder.com/downloads/${PN}-linux-Ubuntu_9.04-i686-0.4.${PV}.tar.bz2 )"
11
12 LICENSE="as-is"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86 -*"
15 IUSE="X"
16
17 RDEPEND="X? ( gnome-base/libglade
18                 dev-python/pygtk )"
19
20 RESTRICT="strip"
21
22 src_unpack() {
23         default
24         mv ${PN}-linux-Ubuntu_* "${S}" || die
25 }
26
27 src_prepare() {
28         sed -i -e "/xml/s:decoderpath:'/usr/share/${PN}':" otrdecoder-gui || die "sed failed"
29 }
30
31 src_install() {
32         dobin otrdecoder || die "dobin failed"
33         if use X; then
34                 insinto /usr/share/${PN}
35                 doins decoder.glade || die "doins failed"
36                 dobin otrdecoder-gui || die "dobin failed"
37         fi
38
39         dodoc README.OTR || die "dodoc failed"
40 }