]> Pileus Git - ~andy/sunrise/blob - media-sound/somax/somax-1.3.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / media-sound / somax / somax-1.3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 IUSE="nls gnome"
8
9 DESCRIPTION="Control and configure soma through a graphic panel"
10 HOMEPAGE="http://www.somasuite.org"
11 SRC_URI="http://www.somasuite.org/src/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 RDEPEND="media-sound/soma
18         >=x11-libs/gtk+-2.0
19         x11-libs/libSM
20         x11-libs/vte
21         gnome? ( x11-libs/gtksourceview
22                 >=gnome-base/libgnomeprintui-2.0 )"
23
24 DEPEND="${RDEPEND}
25         dev-util/pkgconfig"
26
27 src_unpack() {
28         unpack ${A}
29         cd "${S}"
30
31         epatch "${FILESDIR}"/${P}-gtksourceview_env.patch
32 }
33
34 src_compile() {
35         use gnome || myconf="${myconf} --disable-gnomeprint"
36
37         econf \
38                 $(use_enable nls) \
39                 $(use_enable gnome) \
40                 ${myconf} \
41                 || die "econf failed"
42         emake || die "emake failed"
43 }
44
45 src_install() {
46         emake DESTDIR="${D}" install || die "make install failed"
47
48         doicon icons/somax.png
49         make_desktop_entry ${PN} SomaX ${PN}.png AudioVideo;GTK
50
51         dodoc AUTHORS ChangeLog README README.{modules,plugins,library}
52 }
53
54 pkg_postinst() {
55         einfo "If you can afford to donate us some money let us know, we also need"
56         einfo "new and old working hardware."
57         einfo
58         einfo "you can send a mail to"
59         einfo
60         einfo " mail: soma@inventati.org"
61         einfo "  or: bakunin@autistici.org"
62 }