]> Pileus Git - ~andy/sunrise/blob - media-sound/skype-call-recorder/skype-call-recorder-0.7.ebuild
Whitespacing all around the packages. Preparation for review.
[~andy/sunrise] / media-sound / skype-call-recorder / skype-call-recorder-0.7.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit cmake-utils eutils qt4
8
9 DESCRIPTION="Records Skype calls to MP3/Ogg/WAV files"
10 HOMEPAGE="http://atdot.ch/scr/"
11 SRC_URI="http://atdot.ch/scr/files/${PV}/${P}.tar.gz"
12
13 LICENSE="|| ( GPL-2 GPL-3 )"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 RDEPEND="
19         || (
20                 x11-libs/qt-gui:4[dbus]
21                 =x11-libs/qt-4.3*:4
22         )
23         media-sound/lame
24         media-libs/id3lib
25         >=media-libs/libvorbis-1.2.0
26         sys-apps/dbus"
27 DEPEND="${RDEPEND}
28         >=dev-util/cmake-2.4.8"
29
30 QT4_BUILT_WITH_USE_CHECK="dbus"
31
32 pkg_setup() {
33         qt4_pkg_setup
34
35         if built_with_use net-im/skype qt-static; then
36                 ewarn "WARNING: net-im/skype was built with the 'qt-static' USE flag!  Skype Call"
37                 ewarn "Recorder won't be able to connect to Skype!  Reinstall Skype without"
38                 ewarn "'qt-static' to make it work."
39         fi
40 }
41