]> Pileus Git - ~andy/sunrise/blob - media-sound/ripoff/ripoff-0.8.2.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / media-sound / ripoff / ripoff-0.8.2.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Simple GTK+ Based CD Ripper"
6 HOMEPAGE="http://ripoffc.sourceforge.net"
7 SRC_URI="mirror://sourceforge/${PN}c/${P}.tar.gz"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE="flac mp3 vorbis"
13
14 RDEPEND="dev-libs/libcdio
15         media-libs/libcddb
16         >=x11-libs/gtk+-2.6
17         flac? ( media-libs/flac )
18         mp3? ( media-sound/lame )
19         vorbis? ( media-libs/libvorbis )"
20 DEPEND="${RDEPEND}"
21
22 src_compile() {
23         econf \
24                 $(use_enable flac) \
25                 $(use_enable mp3) \
26                 $(use_enable vorbis) \
27                 || die "econf failed"
28
29         emake || die "emake failed"
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die "make install failed"
34         dodoc AUTHORS ChangeLog README TODO
35 }