]> Pileus Git - ~andy/sunrise/blob - media-plugins/vst-headers/vst-headers-2.3.ebuild
media-plugins/vst-headers: fix quoting
[~andy/sunrise] / media-plugins / vst-headers / vst-headers-2.3.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 MY_P="vst_sdk${PV/./_}"
6 MY_P2="vstsdk${PV}"
7
8 DESCRIPTION="Headers from VST SDK. Needed to compile some programs."
9 HOMEPAGE="http://ygrabit.steinberg.de/~ygrabit/public_html/index.html"
10 SRC_URI="${MY_P}.zip"
11
12 LICENSE="SVPSLA"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="app-arch/unzip"
18 RDEPEND=""
19
20 RESTRICT="fetch"
21
22 pkg_nofetch() {
23         einfo "You need to fetch VST Plug-Ins SDK ${PV}"
24         einfo "from http://www.steinberg.de/532+M52087573ab0.html"
25         einfo "and place it on ${DISTDIR}"
26 }
27
28 src_unpack() {
29         unpack ${A}
30         cd "${WORKDIR}"
31         unzip ${MY_P2}.zip
32 }
33
34 src_install() {
35         cd "${WORKDIR}"/${MY_P2}
36         insinto /usr/include/vst
37         doins source/common/AEffect.h
38         doins source/common/aeffectx.h
39 }