]> Pileus Git - ~andy/sunrise/blob - media-plugins/gimp-refocus/gimp-refocus-0.9.0.ebuild
e5688cea27177c998816cbb9a280918daa428284
[~andy/sunrise] / media-plugins / gimp-refocus / gimp-refocus-0.9.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit autotools eutils toolchain-funcs
8
9 MY_PN=${PN#gimp-}
10 MY_P=${MY_PN}-${PV}
11
12 DESCRIPTION="refocus images using FIR Wiener filtering"
13 HOMEPAGE="http://refocus.sourceforge.net"
14 SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="lapack-atlas"
20
21 RDEPEND="lapack-atlas? (
22                 dev-libs/libf2c
23                 sci-libs/lapack-atlas
24         )
25         media-gfx/gimp:2
26         x11-libs/gtk+:2"
27 DEPEND="${RDEPEND}
28         virtual/pkgconfig"
29
30 S=${WORKDIR}/${MY_P}
31
32 src_prepare() {
33         epatch "${FILESDIR}"/${MY_PN}-gimp-2.0.patch
34         epatch "${FILESDIR}"/${MY_PN}-0.9.0-gimp-2.2_rlx.diff
35         epatch "${FILESDIR}"/${PN}-gimp2.6.patch
36         epatch "${FILESDIR}"/${PN}-atlas.patch
37
38         eautoreconf
39 }
40
41 src_configure() {
42         export GIMPTOOL="/usr/bin/gimptool-2.0"
43
44         if use lapack-atlas; then
45                 econf --with-lapack-libs="$($(tc-getPKG_CONFIG) --libs lapack)" \
46                 --with-lapack-includes="$($(tc-getPKG_CONFIG) --cflags lapack)"
47         else
48                 econf
49         fi
50 }
51
52 src_install() {
53         exeinto "$(gimptool-2.0 --gimpplugindir)/plug-ins"
54         doexe src/refocus || die
55 }