]> Pileus Git - ~andy/sunrise/blob - media-plugins/gimp-refocus/gimp-refocus-0.9.0.ebuild
remove lapack-atlas useflag since lapack-atlas has been removed
[~andy/sunrise] / media-plugins / gimp-refocus / gimp-refocus-0.9.0.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit autotools eutils toolchain-funcs
8
9 MY_PN=${PN#gimp-}
10 MY_P=${MY_PN}-${PV}
11
12 DESCRIPTION="refocus images using FIR Wiener filtering"
13 HOMEPAGE="http://refocus.sourceforge.net"
14 SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 RDEPEND="
22         media-gfx/gimp:2
23         x11-libs/gtk+:2"
24 DEPEND="${RDEPEND}
25         virtual/pkgconfig"
26
27 S=${WORKDIR}/${MY_P}
28
29 src_prepare() {
30         epatch "${FILESDIR}"/${MY_PN}-gimp-2.0.patch
31         epatch "${FILESDIR}"/${MY_PN}-0.9.0-gimp-2.2_rlx.diff
32         epatch "${FILESDIR}"/${PN}-gimp2.6.patch
33         epatch "${FILESDIR}"/${PN}-atlas.patch
34
35         eautoreconf
36 }
37
38 src_configure() {
39         export GIMPTOOL="/usr/bin/gimptool-2.0"
40
41         econf
42 }
43
44 src_install() {
45         exeinto "$(gimptool-2.0 --gimpplugindir)/plug-ins"
46         doexe src/refocus || die
47 }