]> Pileus Git - ~andy/sunrise/blob - media-libs/ucil/ucil-0.9.8.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / media-libs / ucil / ucil-0.9.8.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils
8
9 DESCRIPTION="Overlays text and graphics on video images"
10 HOMEPAGE="http://unicap-imaging.org/"
11 SRC_URI="http://unicap-imaging.org/downloads/lib${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="alsa debug doc nls png theora"
17
18 RDEPEND="dev-libs/glib:2
19         ~media-libs/unicap-${PV}
20         x11-libs/pango
21         alsa? ( media-libs/alsa-lib )
22         nls? ( virtual/libintl )
23         png? ( media-libs/libpng )
24         theora? ( media-libs/libtheora )"
25 DEPEND="${RDEPEND}
26         doc? ( dev-util/gtk-doc )"
27
28 S=${WORKDIR}/lib${P}
29
30 src_prepare() {
31         # patch submitted upstream at https://bugs.launchpad.net/unicap/+bug/584164
32         epatch "${FILESDIR}/libpng14.patch"
33 }
34
35 src_configure() {
36         # The Unicap author recommended leaving avcodec (ffmpeg) support disabled:
37         # http://unicap-imaging.org/blog/index.php?/archives/20-Unicap-0.9.3-and-UCView-0.22-released.html#c46
38
39         econf --disable-ucil-avcodec \
40                 $(use_enable alsa ucil-alsa) \
41                 $(use_enable debug debug-ucil) \
42                 $(use_enable doc gtk-doc) \
43                 $(use_enable nls) \
44                 $(use_enable png ucil-png) \
45                 $(use_enable theora ucil-theora)
46 }
47
48 src_install() {
49         emake DESTDIR="${D}" install || die
50         dodoc AUTHORS ChangeLog NEWS README || die
51 }