]> Pileus Git - ~andy/sunrise/blob - media-libs/libbsb/libbsb-0.0.7.ebuild
media-video/ imagination: moved to gx86 by me
[~andy/sunrise] / media-libs / libbsb / libbsb-0.0.7.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 DESCRIPTION="A portable C library for reading and writing BSB format image files"
8 HOMEPAGE="http://libbsb.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="media-libs/libpng
17         media-libs/tiff"
18 RDEPEND="${DEPEND}"
19
20 # "make check" in 0.0.7 fails with newer tiff versions (4.0.0) altough the
21 # tools work perfectly, so restrict test until this is fixed upstream
22 RESTRICT="test"
23
24 src_install() {
25         emake DESTDIR="${D}" install || die "Install failed"
26         dodoc README AUTHORS || die
27 }