]> Pileus Git - ~andy/sunrise/blob - media-gfx/tintii/tintii-2.4.0.ebuild
media-gfx/tintii: The ebuild took now into account flags from make.conf, thantk to...
[~andy/sunrise] / media-gfx / tintii / tintii-2.4.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6 WX_GTK_VER="2.9"
7
8 inherit scons-utils toolchain-funcs wxwidgets
9
10 DESCRIPTION="Photo filter, striking colour pops in seconds"
11 HOMEPAGE="http://www.indii.org/software/tintii"
12 SRC_URI="mirror://sourceforge/tint/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="doc"
18
19 RDEPEND="x11-libs/wxGTK:${WX_GTK_VER}[X]"
20 DEPEND="${RDEPEND}
21         dev-libs/boost
22         doc? ( app-doc/doxygen )"
23
24 src_compile() {
25         escons CXX="$(tc-getCXX)" \
26                 CXXFLAGS="${CXXFLAGS} `wx-config --cxxflags`" \
27                 LINKFLAGS="`wx-config --libs` `wx-config --libs aui`" || die
28
29         if use doc ; then
30                 doxygen Doxyfile || die
31         fi;
32 }
33
34 src_install() {
35         dobin ${PN} || die
36         dodoc README.txt || die
37
38         if use doc ; then
39                 dohtml srcdocs/html/* || die
40         fi;
41 }