]> Pileus Git - ~andy/sunrise/blob - media-gfx/ktikz/ktikz-0.9.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / media-gfx / ktikz / ktikz-0.9.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils qt4-r2
8
9 DESCRIPTION="A QT4-based editor for the TikZ language"
10 HOMEPAGE="http://www.hackenberger.at/blog/ktikz-editor-for-the-tikz-language"
11 SRC_URI="http://www.hackenberger.at/${PN}/${P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="debug"
16
17 DEPEND="dev-qt/qtgui:4
18         app-text/poppler[qt4]
19         virtual/latex-base
20         dev-texlive/texlive-latexextra
21         dev-tex/pgf"
22 RDEPEND="${DEPEND}"
23
24 DOCS="Changelog TODO"
25
26 src_prepare() {
27         # don't install desktop icon (and cause sandbox violation)
28         sed -i -e '72,79d' src/src.pro || die "sed failed"
29         # ... and libs are not equal ldflags, make that sure:
30         sed -i -e 's|QMAKE_LFLAGS|LIBS|' macros.pri || die "sed failed"
31 }
32
33 src_configure() {
34         KDECONFIG="CONFIG-=usekde"
35         eqmake4 ${PN}.pro PREFIX="${D}/usr" "CONFIG+=nostrip" "$KDECONFIG"
36 }
37
38 src_install() {
39         qt4-r2_src_install
40         newicon src/images/${PN}-128.png ${PN}.png || die "Cannot install icon"
41         make_desktop_entry ${PN} KtikZ ${PN} Graphics \
42                 || die "Cannot create desktop entry"
43 }