]> Pileus Git - ~andy/sunrise/blob - media-gfx/fontmatrix/fontmatrix-0.6.0.ebuild
media-gfx/fontmatrix: Version bump, slightly adjustments
[~andy/sunrise] / media-gfx / fontmatrix / fontmatrix-0.6.0.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6
7 inherit cmake-utils qt4
8
9 DESCRIPTION="A font manager"
10 HOMEPAGE="http://www.fontmatrix.net/"
11 SRC_URI="http://www.fontmatrix.net/archives/${P}-Source.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug"
17
18 RDEPEND="x11-libs/qt-core:4
19         x11-libs/qt-gui:4
20         x11-libs/qt-svg:4
21         x11-libs/qt-webkit:4
22         media-libs/freetype:2"
23 DEPEND=${RPEDEND}
24
25 S=${WORKDIR}/${P}-Source
26
27 src_compile() {
28         local mycmakeargs="-DOWN_SHAPER=1"
29         cmake-utils_src_compile
30 }
31
32 src_install() {
33         dobin "${CMAKE_BUILD_DIR}"/src/${PN} || die
34         doman ${PN}.1 || die
35         domenu ${PN}.desktop || die
36         dodoc ChangeLog TODO || die
37 }
38
39 pkg_postinst() {
40         elog "If you encounter problems or just have questions or if you have"
41         elog " suggestions, please take time to suscribe to the undertype-users"
42         elog " mailing list ( https://mail.gna.org/listinfo/undertype-users )."
43         elog " If you want to reach us quickly, come to #fontmatrix at Freenode."
44 }