]> Pileus Git - ~andy/sunrise/blob - media-gfx/fontmatrix/fontmatrix-0.6.0.ebuild
28439ea17cd462a4a418f68704c680109c1d80dc
[~andy/sunrise] / media-gfx / fontmatrix / fontmatrix-0.6.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit qt4-r2 cmake-utils
8
9 DESCRIPTION="A font manager"
10 HOMEPAGE="http://oep-h.com/fontmatrix/"
11 # old link dead, no official one yet ( Mar 21 2012 )
12 SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/${PN}/${P}-Source.tar.gz/6a00c9448a50d3bab5acb4145f778f2d/${P}-Source.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="debug"
18
19 RDEPEND="dev-libs/qtgui:4
20         dev-libs/qtsql:4
21         dev-libs/qtsvg:4
22         dev-libs/qtwebkit:4
23         media-libs/freetype:2"
24 DEPEND=${RPEDEND}
25
26 S=${WORKDIR}/${P}-Source
27
28 src_configure() {
29         local mycmakeargs="-DOWN_SHAPER=1"
30         cmake-utils_src_configure
31 }
32
33 src_install() {
34         dobin "${CMAKE_BUILD_DIR}"/src/${PN}
35         doman ${PN}.1
36         domenu ${PN}.desktop
37         doicon ${PN}.png
38         dodoc ChangeLog TODO
39 }
40
41 pkg_postinst() {
42         elog "If you encounter problems or just have questions or if you have"
43         elog "suggestions, please take time to suscribe to the undertype-users"
44         elog "mailing list ( https://mail.gna.org/listinfo/undertype-users )."
45         elog "If you want to reach us quickly, come to #fontmatrix at Freenode."
46 }