]> Pileus Git - ~andy/sunrise/blob - media-gfx/clens/clens-0.3.1.ebuild
2ef1f92326bc2fdb6c00a5b3d9d5fc13237a7475
[~andy/sunrise] / media-gfx / clens / clens-0.3.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit cvs
6
7 ECVS_SERVER="panotools.cvs.sourceforge.net:/cvsroot/panotools"
8 ECVS_MODULE="clens"
9 # There is no 0.3.1 branch, we use a date instead
10 ECVS_CO_OPTS="-D 6/19/06"
11 ECVS_UP_OPTS="-dP -D 6/19/06"
12
13 DESCRIPTION="A command-line version of PTLens"
14 SRC_URI=""
15 HOMEPAGE="http://panotools.sourceforge.net/"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~x86"
20 IUSE=""
21
22 DEPEND="media-gfx/ptlens-profiles
23         >=media-libs/libpano13-2.8.4"
24 RDEPEND="${DEPEND}"
25
26 PTLENS_PROFILES="/usr/share/ptlens/profiles/profile.txt"
27
28 S="${WORKDIR}/${ECVS_MODULE}"
29
30 src_compile() {
31         ./bootstrap || die "bootstrap failed"
32         econf || die "econf failed"
33         emake || die "emake failed"
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" install || die "emake install failed"
38         echo "CLENS_PROFILE=\"${PTLENS_PROFILES}\"" > 99clens
39         doenvd 99clens
40 }