]> Pileus Git - ~andy/sunrise/blob - media-gfx/argyllcms/argyllcms-1.2.1.ebuild
[media-gfx/argyllcms] Version bump with minor improvements.
[~andy/sunrise] / media-gfx / argyllcms / argyllcms-1.2.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 MY_P="Argyll_V${PV}"
6 DESCRIPTION="Open source, ICC compatible color management system"
7 HOMEPAGE="http://www.argyllcms.com/"
8 SRC_URI="http://www.argyllcms.com/${MY_P}_src.zip"
9
10 LICENSE="AGPL-3"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="doc"
14
15 RDEPEND="media-libs/tiff
16         media-libs/jpeg
17         sys-libs/zlib
18         x11-libs/libX11
19         x11-libs/libXau
20         x11-libs/libXdmcp
21         x11-libs/libXext
22         x11-libs/libXinerama
23         x11-libs/libXrandr
24         x11-libs/libXxf86vm
25         x11-libs/libXScrnSaver"
26 DEPEND="${RDEPEND}
27         app-arch/unzip
28         dev-util/ftjam"
29
30 S="${WORKDIR}/${MY_P}"
31
32 src_compile() {
33         echo "LINKFLAGS += ${LDFLAGS} ;" >> Jamtop
34         emake || die "emake failed"
35 }
36
37 src_install() {
38         emake install || die
39
40         rm bin/License.txt || die
41         dobin bin/* || die
42
43         if use doc; then
44                 dohtml doc/* || die
45         fi
46
47         dodoc log.txt Readme.txt ttbd.txt notes.txt || die
48
49         insinto /usr/share/${PN}/ref
50         doins   ref/*  || die
51
52         insinto /etc/udev/rules.d
53         doins libusb/55-Argyll.rules
54 }
55
56 pkg_postinst() {
57         elog
58         elog "If you have a Spyder2 you need to extract the firmware"
59         elog "from the spyder2_setup.exe (ColorVision CD)"
60         elog "and store it as /usr/bin/spyd2PLD.bin"
61         elog
62         elog "For further info on setting up instrument access read"
63         elog "http://www.argyllcms.com/doc/Installing_Linux.html"
64         elog
65 }