]> Pileus Git - ~andy/sunrise/blob - mail-filter/libdkim/libdkim-1.0.21.ebuild
97f85efb3ee80cf924df0872a7f8a8f0b21372c7
[~andy/sunrise] / mail-filter / libdkim / libdkim-1.0.21.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 inherit eutils multilib toolchain-funcs
8
9 DESCRIPTION="A library to verify and create signatures of e-mail headers."
10 HOMEPAGE="http://libdkim.sourceforge.net"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-libs/openssl
19         app-arch/unzip"
20 RDEPEND="dev-libs/openssl"
21
22 S=${WORKDIR}/${PN}/src
23
24 src_prepare() {
25         ecvs_clean
26         # upstream claims to be portable, but isn't very
27         epatch "${FILESDIR}/${PN}-gentoo.patch"
28         epatch "${FILESDIR}/${PN}-extra-options.patch"
29 }
30
31 src_compile() {
32         tc-export CXX
33         emake LIBDIR=$(get_libdir)
34 }
35
36 src_install() {
37         emake DESTDIR="${ED}" install
38         dodoc ../README
39 }