]> Pileus Git - ~andy/sunrise/blob - mail-filter/libdkim/libdkim-1.0.21.ebuild
mail-filter/libdkim: Update Ebuild for bug 262919; thanks to pva
[~andy/sunrise] / mail-filter / libdkim / libdkim-1.0.21.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 inherit eutils multilib toolchain-funcs
8
9 DESCRIPTION="A library to verify and create signatures of e-mail headers."
10 HOMEPAGE="http://libdkim.sourceforge.net"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND="dev-libs/openssl
19         app-arch/unzip"
20 RDEPEND="!mail-filter/libdkim-exim
21         dev-libs/openssl"
22
23 S=${WORKDIR}/${PN}/src
24
25 src_prepare() {
26         ecvs_clean
27         # upstream claims to be portable, but isn't very
28         epatch "${FILESDIR}/${PN}-gentoo.patch"
29         epatch "${FILESDIR}/${PN}-extra-options.patch"
30 }
31
32 src_compile() {
33         tc-export CXX
34         emake LIBDIR=$(get_libdir)
35 }
36
37 src_install() {
38         emake DESTDIR="${ED}" install
39         dodoc ../README
40 }