]> Pileus Git - ~andy/sunrise/blob - mail-client/alpine/alpine-2.00.ebuild
ea9e7e0239a086374e1f019015cb28e0be9f7c91
[~andy/sunrise] / mail-client / alpine / alpine-2.00.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6
7 inherit eutils
8
9 DESCRIPTION="Fast and easy to use command line email client based on Pine."
10 HOMEPAGE="http://www.washington.edu/alpine/
11 http://staff.washington.edu/chappa/alpine/"
12 SRC_URI="ftp://ftp.cac.washington.edu/${PN}/${P}.tar.bz2
13         chappa? (
14         http://dev.gentooexperimental.org/~tommy/distfiles/chappa-${P}.patch.gz )"
15 # When the patch is not needed anymore inform Tommy[D] so he can
16 # remove the patch from his home directory.
17
18 LICENSE="Apache-2.0"
19 SLOT="0"
20 KEYWORDS="~amd64 ~x86"
21 IUSE="+chappa +ipv6 kerberos ldap +nls +mime +ssl tcl +threads"
22
23 DEPEND="sys-libs/ncurses
24         ssl? ( dev-libs/openssl )
25         ldap? ( net-nds/openldap )
26         kerberos? ( app-crypt/mit-krb5 )"
27 RDEPEND="${DEPEND}
28         app-misc/mime-types"
29
30 src_unpack() {
31         unpack ${P}.tar.bz2
32         cd "${S}"
33         epatch "${DISTDIR}/chappa-${P}.patch.gz"
34 }
35
36 src_compile() {
37         econf \
38                 $( use_with ssl ) \
39                 $( use_with kerberos krb5 ) \
40                 $( use_with ldap ) \
41                 $( use_with mime smime ) \
42                 $( use_with ipv6 ) \
43                 $( use_with tcl ) \
44                 $( use_with threads pthread )
45
46         emake || die "Build failed."
47 }
48
49 src_install() {
50         emake DESTDIR="${D}" install || die "Installation failed"
51         dodoc README NOTICE || die "dodoc failed."
52 }
53
54 pkg_postinst() {
55         elog "For additional functionality you may want to"
56         elog "install some of the programs listed below"
57         elog " * aspell for spell checking"
58         elog " * topal for encryption and signing"
59 }
60