]> Pileus Git - ~andy/sunrise/blob - gnome-extra/gnome-hdaps-applet/gnome-hdaps-applet-20081204.ebuild
gnome-extra/gnome-hdaps-applet: New ebuild for bug 272212
[~andy/sunrise] / gnome-extra / gnome-hdaps-applet / gnome-hdaps-applet-20081204.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 ETYPE=gcc-library
8 inherit eutils multilib toolchain-funcs
9
10 DESCRIPTION="Visualization of the Hard Disc Active Protection System State as Gnome applet"
11 HOMEPAGE="http://www.zen24593.zen.co.uk/hdaps/"
12 SRC_URI="http://www.zen24593.zen.co.uk/hdaps/${P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 COMMON_DEPEND="gnome-base/gnome-panel
20         x11-libs/gtk+:2"
21 DEPEND="${COMMON_DEPEND}
22         dev-util/pkgconfig"
23 RDEPEND="${COMMON_DEPEND}
24         app-laptop/hdapsd"
25
26 S=${WORKDIR}
27
28 src_prepare() {
29         epatch "${FILESDIR}"/${P}-include-and-unused.patch
30 }
31
32 src_compile() {
33         $(tc-getCC) -c -Wall ${CFLAGS} \
34                 $($(tc-getPKG_CONFIG) --cflags gtk+-2.0) \
35                 $($(tc-getPKG_CONFIG) --cflags libpanelapplet-2.0) \
36                 -o ${PN}.o ${PN}.c || die
37         $(tc-getCC) -Wall ${LDFLAGS} -Wl,--as-needed \
38                 -o ${PN} ${PN}.o \
39                 $($(tc-getPKG_CONFIG) --libs-only-L gtk+-2.0) \
40                 $($(tc-getPKG_CONFIG) --libs-only-L libpanelapplet-2.0) \
41                 -lgtk-x11-2.0 -lpanel-applet-2 || die
42 }
43
44 src_install() {
45         dobin ${PN} || die
46         insinto /usr/share/pixmaps/${PN}
47         doins hdaps-*.png || die
48         insinto /usr/$(get_libdir)/bonobo/servers
49         doins GNOME_HDAPS_StatusApplet.server || die
50 }