]> Pileus Git - ~andy/sunrise/blob - games-strategy/freesynd/freesynd-9999.ebuild
Automatic update to use.local.desc
[~andy/sunrise] / games-strategy / freesynd / freesynd-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit cmake-utils eutils subversion games
8
9 DESCRIPTION="A cross-platform reimplementation of engine for the classic Bullfrog game, Syndicate"
10 HOMEPAGE="http://freesynd.sourceforge.net/"
11 ESVN_REPO_URI="https://${PN}.svn.sourceforge.net/svnroot/${PN}/${PN}/trunk"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE=""
17
18 RDEPEND="media-libs/libogg
19         media-libs/libpng:0
20         media-libs/libsdl[X,audio,video]
21         media-libs/libvorbis
22         media-libs/sdl-mixer[mp3,vorbis]
23         media-libs/sdl-image[png]"
24 DEPEND="${RDEPEND}"
25
26 CMAKE_IN_SOURCE_BUILD=1
27
28 src_prepare() {
29         sed \
30                 -e "/freesynd_data_dir/s#/usr/share#${GAMES_DATADIR}#" \
31                 -e "/freesynd_data_dir/s/#//" \
32                 -i ${PN}.ini || die
33 }
34
35 src_configure() {
36         cmake-utils_src_configure
37 }
38
39 src_install() {
40         dogamesbin src/${PN} || die
41         insinto "${GAMES_DATADIR}"/${PN}
42         doins -r data || die
43         newicon icon/sword.png ${PN}.png || die
44         make_desktop_entry ${PN} ${PN} ${PN}
45         dodoc NEWS README INSTALL AUTHORS || die
46 }
47
48 pkg_postinst() {
49         games_pkg_postinst
50         elog "You have to set \"data_dir = /my/path/to/synd-data\""
51         elog "in \"~/.${PN}/${PN}.ini\"."
52 }