]> Pileus Git - ~andy/sunrise/blob - games-rpg/simon1-demo/simon1-demo-1.ebuild
831085b5c8e7229d757111a21737525458b47e46
[~andy/sunrise] / games-rpg / simon1-demo / simon1-demo-1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit games
6
7 DESCRIPTION="Simon the Sorcerer (interactive demo)"
8 HOMEPAGE="http://www.adventuresoft.com/gs1.html"
9 SRC_URI="http://gentooexperimental.org/~unlord/simon1demo_acorn.rar"
10
11 LICENSE="freedist"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15 RESTRICT="strip"
16
17 RDEPEND=">=games-engines/scummvm-0.8.2"
18 DEPEND="|| (
19         app-arch/unrar
20         app-arch/rar )"
21
22 S=${WORKDIR}
23 dir=${GAMES_DATADIR}/${PN}
24
25 src_install() {
26         insinto "${dir}"
27         doins DATA EFFECTS SIMON || die "doins failed"
28         doins -r EXECUTE || die "doins -r failed"
29
30         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" simon1"
31         doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
32         make_desktop_entry ${PN} "Simon the Sorcerer 1 (Demo)" ${PN}.png
33
34         prepgamesdirs
35 }