]> Pileus Git - ~andy/sunrise/blob - games-rpg/ft-demo/ft-demo-1.ebuild
games-rpg/ft-demo: New ebuild for bug 142319
[~andy/sunrise] / games-rpg / ft-demo / ft-demo-1.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="Full Throttle (Demo)"
8 HOMEPAGE="http://www.lucasarts.com/games/fullthrottle/"
9 SRC_URI="http://gentooexperimental.org/~unlord/ft-demo.zip"
10
11 LICENSE="freedist"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64"
14 IUSE=""
15 RESTRICT="strip"
16
17 RDEPEND=">=games-engines/scummvm-0.8.2"
18 DEPEND="app-arch/unzip"
19
20 S=${WORKDIR}/ftdemo
21 dir=${GAMES_DATADIR}/${PN}
22
23 src_install() {
24         insinto "${dir}"
25         doins ft.{000,001} monster.sou || die "doins failed"
26         doins -r data video || die "doins -r failed"
27
28         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" ft"
29         doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
30         make_desktop_entry ${PN} "Full Throttle (Demo)" ${PN}.png
31
32         prepgamesdirs
33 }