]> Pileus Git - ~andy/sunrise/blob - games-rpg/dig-demo/dig-demo-1.ebuild
36ddadacefb4c08271088ce0c868d03e9010de94
[~andy/sunrise] / games-rpg / dig-demo / dig-demo-1.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="The Dig (interactive demo)"
8 HOMEPAGE="http://dig.mixnmojo.com/"
9 SRC_URI="http://gentooexperimental.org/~unlord/${PN}.rar"
10
11 LICENSE="freedist"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64"
14 IUSE=""
15 RESTRICT="strip"
16
17 RDEPEND=">=games-engines/scummvm-0.8.2"
18 DEPEND="|| (
19         app-arch/unrar
20         app-arch/rar )"
21
22 S=${WORKDIR}/digdemo
23 dir=${GAMES_DATADIR}/${PN}
24
25 src_install() {
26         insinto "${dir}"
27         doins dig.la0 dig.la1 || die "doins failed"
28         doins -r audio video || die "doins -r failed"
29
30         games_make_wrapper ${PN} "scummvm -f -p \"${dir}\" dig"
31         doicon "${FILESDIR}/${PN}.png" || die "doicon failed"
32         make_desktop_entry ${PN} "The Dig (Demo)" ${PN}.png
33
34         prepgamesdirs
35 }