]> Pileus Git - ~andy/sunrise/blob - games-roguelike/powder/powder-110.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / games-roguelike / powder / powder-110.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 MY_P=${P/-/}_src
8
9 DESCRIPTION="A game in the genre of Rogue, Nethack, and Diablo. Emphasis is on tactical play."
10 HOMEPAGE="http://www.zincland.com/powder/"
11 SRC_URI="http://www.zincland.com/${PN}/release/${MY_P}.tar.gz"
12
13 LICENSE="powder_license"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND="media-libs/libsdl"
19 RDEPEND="${DEPEND}"
20
21 S=${WORKDIR}/${MY_P}
22
23 src_unpack() {
24         unpack ${A}
25         epatch "${FILESDIR}/${P}-make.patch"
26 }
27
28 src_compile() {
29         cd port/linux
30         CXXFLAGS="${CXXFLAGS} -DCHANGE_WORK_DIRECTORY" emake || die
31 }
32
33 src_install() {
34         dogamesbin port/linux/${PN} || die "dogamesbin failed"
35         dodoc README.TXT CREDITS.TXT || die "dodoc failed"
36         prepgamesdirs
37 }