]> Pileus Git - ~andy/sunrise/blob - games-misc/digital/digital-1.1-r2.ebuild
games-rpg/digital: Updated ebuild to work with revamped renpy package (thanks, hasufell)
[~andy/sunrise] / games-misc / digital / digital-1.1-r2.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_6,2_7} )
7
8 inherit eutils gnome2-utils games python-single-r1
9
10 DESCRIPTION="A computer mystery/romance game set five minutes into the future of 1988"
11 HOMEPAGE="http://scoutshonour.com/digital/"
12 SRC_URI="http://digital.artfulgamer.com/${P}.tar.bz2
13         http://www.scoutshonour.com/lilyofthevalley/${P}.tar.bz2"
14
15 LICENSE="CC-BY-NC-SA-3.0"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 DEPEND="${PYTHON_DEPS}"
21 RDEPEND="${DEPEND}
22         games-engines/renpy:6.14[${PYTHON_USEDEP}]"
23
24 S=${WORKDIR}/Digital-linux-x86
25
26 pkg_setup() {
27         games_pkg_setup
28         python-single-r1_pkg_setup
29 }
30
31 src_prepare() {
32         cat <<EOF >"${T}"/digital || die
33 #!/bin/sh -e
34 cd "${GAMES_DATADIR}/${PN}"
35 export PYTHONPATH="$(python_get_sitedir)/renpy614"
36 exec "${PYTHON}" Digital.py
37 EOF
38 }
39
40 src_install() {
41         exeinto "${GAMES_BINDIR}"
42         doexe "${T}"/digital
43
44         insinto "${GAMES_DATADIR}/${PN}"
45         doins -r Digital.py common game renpy
46
47         dohtml README.html
48
49         newicon -s 128 game/icon.png ${PN}.png
50         make_desktop_entry ${PN} "Digital: A love story"
51
52         prepgamesdirs
53 }
54
55 pkg_preinst() {
56         games_pkg_preinst
57         gnome2_icon_savelist
58 }
59
60 pkg_postinst() {
61         games_pkg_postinst
62         gnome2_icon_cache_update
63 }
64
65 pkg_postrm() {
66         gnome2_icon_cache_update
67 }