]> Pileus Git - ~andy/sunrise/blob - games-fps/vavoom-models/vavoom-models-1.4.3.ebuild
be46ac69f4c54edb714e0c7fe72c139db3b1c0dd
[~andy/sunrise] / games-fps / vavoom-models / vavoom-models-1.4.3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit games
6
7 DESCRIPTION="3D models of Doom/Heretic/Hexen/Strife for Vavoom"
8 HOMEPAGE="http://www.vavoom-engine.com/"
9
10 SRC_URI="doom? ( mirror://sourceforge/vavoom/vmodels-doom-${PV}.zip )
11         heretic? ( mirror://sourceforge/vavoom/vmodels-heretic-${PV}.zip )
12         hexen? ( mirror://sourceforge/vavoom/vmodels-hexen-${PV}.zip )
13         strife? ( mirror://sourceforge/vavoom/vmodels-strife-${PV}.zip )
14         !doom? ( !heretic? ( !hexen? ( !strife? (
15                 mirror://sourceforge/vavoom/vmodels-doom-${PV}.zip
16                 mirror://sourceforge/vavoom/vmodels-heretic-${PV}.zip
17                 mirror://sourceforge/vavoom/vmodels-hexen-${PV}.zip
18                 mirror://sourceforge/vavoom/vmodels-strife-${PV}.zip ) ) ) )"
19
20 LICENSE="as-is"
21 SLOT="0"
22 KEYWORDS="~amd64 ~x86"
23 IUSE="doom heretic hexen strife"
24
25 DEPEND="app-arch/unzip"
26 RDEPEND="games-fps/vavoom"
27
28 S=${WORKDIR}
29
30 src_unpack() {
31         unpack ${A}
32
33         cd "${S}"
34         # Move docs outside of basev dir
35         for x in $(ls -1 basev) ; do
36                 mv basev/${x}/xmodels.txt ${x}-models.txt
37         done
38 }
39
40 src_install() {
41         dodoc *.txt || die "dodoc failed"
42
43         cd basev
44         insinto "${GAMES_DATADIR}/vavoom/basev/"
45         doins -r * || die "doins failed"
46
47         prepgamesdirs
48 }