]> Pileus Git - ~andy/sunrise/blob - games-fps/hexen2-demodata/hexen2-demodata-1.4.3.ebuild
add missing die
[~andy/sunrise] / games-fps / hexen2-demodata / hexen2-demodata-1.4.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils games
8
9 MY_PN="hexen2"
10 MY_P="${MY_PN}demo-${PV}"
11
12 DESCRIPTION="Demo data for Hexen 2"
13 HOMEPAGE="http://uhexen2.sourceforge.net/"
14 SRC_URI="amd64? ( mirror://sourceforge/u${MY_PN}/${MY_P}-linux-x86_64.tgz )
15         ppc? ( mirror://sourceforge/u${MY_PN}/${MY_P}-linux-i586.tgz )
16         x86? ( mirror://sourceforge/u${MY_PN}/${MY_P}-linux-i586.tgz )"
17
18 LICENSE="as-is"
19 SLOT="0"
20 KEYWORDS="~amd64 ~ppc ~x86"
21 IUSE=""
22
23 S=${WORKDIR}/${MY_P}
24 dir=${GAMES_DATADIR}/${MY_PN}
25
26 src_install() {
27         insinto "${GAMES_DATADIR}"/${MY_PN}/demo
28         doins -r data1 || die
29
30         # All the docs are regarding uhexen2, rather than the demo data.
31
32         prepgamesdirs
33 }
34
35 pkg_postinst() {
36         games_pkg_postinst
37
38         if has_version "games-fps/uhexen2[-demo]" ; then
39                         ewarn "emerge uhexen2 with its 'demo' USE flag, so that"
40                         ewarn "it uses the demo data directory. Or run it with:"
41                         ewarn "   uhexen2 -game demo"
42                         echo
43         else
44                 einfo "This is just the demo data. To play, emerge a client"
45                 einfo "such as uhexen2 with its 'demo' USE flag."
46                 echo
47         fi
48 }