]> Pileus Git - ~andy/sunrise/blob - games-arcade/vodovod/vodovod-1.10.ebuild
games-arcade/vodovod: New Ebuild for bug 183731
[~andy/sunrise] / games-arcade / vodovod / vodovod-1.10.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 DESCRIPTION="A free cross-platform pipe connecting game"
8 HOMEPAGE="http://home.gna.org/vodovod/"
9 SRC_URI="http://download.gna.org/vodovod/${P}-src.tar.gz"
10
11 S="${WORKDIR}/${P}-src"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="x86"
15 IUSE=""
16
17 DEPEND="media-libs/libsdl
18                 media-libs/sdl-mixer
19                 media-libs/sdl-image"
20
21 src_unpack() {
22         unpack ${A}
23         cd "${S}"
24         sed -e 's:"\(data/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i *.cpp
25 }
26
27 src_install() {
28         dogamesbin "${PN}" || die "dogamesbin failed"
29         insinto "${GAMES_DATADIR}/${PN}/data"
30         doins data/* || die "doins failed"
31         #doicon ${DISTDIR}/${PN}.png
32         make_desktop_entry ${PN} "Vodovod"
33         prepgamesdirs
34 }