]> Pileus Git - ~andy/sunrise/blob - games-arcade/tuxanci/tuxanci-0.18_rc1.ebuild
games-arcade/tuxanci: Fix dependencies, add ~amd64 keyword
[~andy/sunrise] / games-arcade / tuxanci / tuxanci-0.18_rc1.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils games
6
7 MY_P=${P/_/}
8
9 DESCRIPTION="First Cushion Shooter! A remake of well-known Czech game Bulanci."
10 SRC_URI="http://tuxanci.tuxportal.cz/releases/${MY_P}.tar.bz2"
11 HOMEPAGE="http://tuxanci.tuxportal.cz"
12
13 KEYWORDS="~amd64 ~x86 ~x86-fbsd"
14 LICENSE="GPL-2"
15 SLOT="0"
16
17 DEPEND=">=media-libs/libsdl-1.2.7
18         media-libs/sdl-ttf
19         media-libs/sdl-image
20         media-libs/sdl-mixer
21         media-libs/sdl-net
22         media-libs/sdl-ttf"
23 RDEPEND="${DEPEND}"
24
25 S="${WORKDIR}/${MY_P}"
26 GAMES_USE_SDL="noaudio"
27
28 pkg_setup() {
29         games_pkg_setup
30
31         if ! built_with_use media-libs/sdl-image png ; then
32                 eerror "media-libs/sdl-image is missing png support."
33                 die "Recompile media-libs/sdl-image with USE=\"png\""
34         fi
35
36         if ! built_with_use media-libs/sdl-mixer vorbis ; then
37                 eerror "media-libs/sdl-mixer is missing png support."
38                 die "Recompile media-libs/sdl-mixer with USE=\"vorbis\""
39         fi
40 }
41
42 src_install() {
43         emake DESTDIR="${D}" install || die "Installation failed."
44         dodoc README ChangeLog
45         prepgamesdirs
46 }