]> Pileus Git - ~andy/sunrise/blob - games-arcade/retrobattle/retrobattle-1.0.0.ebuild
98863eea5bbc23ef8e7e681aee5ff79d66ee0b11
[~andy/sunrise] / games-arcade / retrobattle / retrobattle-1.0.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit games
8
9 DESCRIPTION="A NES-like platform arcade game"
10 HOMEPAGE="http://remar.se/andreas/retrobattle/"
11 SRC_URI="${HOMEPAGE}files/${PN}-src-${PV}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17 RESTRICT="test"
18
19 RDEPEND="
20         media-libs/libsdl[X,audio,video]
21         media-libs/sdl-mixer
22         "
23 DEPEND="${RDEPEND}"
24
25 S=${WORKDIR}/${PN}-src-${PV}/src/
26
27 src_prepare() {
28         epatch "${FILESDIR}"/${P}-build.patch
29 }
30
31 src_install() {
32         insinto "${GAMES_DATADIR}"/${PN}
33         doins -r "${WORKDIR}"/${PN}-src-${PV}/data
34
35         newgamesbin "${WORKDIR}"/${PN}-src-${PV}/${PN} ${PN}.bin
36         games_make_wrapper ${PN} "${PN}.bin \"${GAMES_DATADIR}/${PN}\""
37         make_desktop_entry ${PN} &{PN} ""
38
39         dodoc "../manual.txt" "../README"
40
41         prepgamesdirs
42 }