]> Pileus Git - ~andy/sunrise/blob - games-action/tacticsgame/tacticsgame-0.3.ebuild
9b22bdb71453dc66f9de7f33531360614429154a
[~andy/sunrise] / games-action / tacticsgame / tacticsgame-0.3.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit games
6
7 DESCRIPTION="Tactics Squad is a real-time tactical game set in a futuristic environment."
8 HOMEPAGE="http://sourceforge.net/projects/tacticsgame/"
9 SRC_URI="mirror://sourceforge/${PN}/Tactics_Squad_${PV}_Linux.tar.gz"
10 LICENSE="GPL-2"
11
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
15
16 DEPEND="media-libs/libsdl
17         virtual/opengl"
18 RDEPEND="${DEPEND}"
19
20 S="${WORKDIR}/TS"
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         sed -i -e "s:-O3:${CXXFLAGS}:" Makefile || die "Sed Makefile failed"
26 }
27
28 src_install() {
29         dogamesbin Tactics || die "Install Failed"
30         newdoc "Change Log.txt" ChangeLog.txt || die "Doc install failed"
31         newdoc "Release Notes.txt" ReleaseNotes.txt || die "Doc install failed"
32         prepgamesdirs
33 }