]> Pileus Git - ~andy/sunrise/blob - games-action/ballistics-demo/ballistics-demo-1.03.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / games-action / ballistics-demo / ballistics-demo-1.03.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 inherit eutils games
8
9 DESCRIPTION="Super-fast 3D racing on hover bikes"
10 HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=ballistics"
11 # Patches: http://updatefiles.linuxgamepublishing.com/ballistics-demo/
12 # Unversioned filename, grrr (is pre-patched).
13 SRC_URI="http://demofiles.linuxgamepublishing.com/ballistics/${PN}.run"
14
15 LICENSE="as-is"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19 RESTRICT="mirror strip"
20
21 # Not bothering with "dynamic" USE flag.
22 # Uses OSS for audio.
23 # dynamic? ( dev-games/libgrapple )
24 RDEPEND="
25         x86? (
26                 media-libs/libsdl
27                 x11-libs/gtk+:2
28                 x11-libs/libX11
29                 x11-libs/libXau
30                 x11-libs/libXdmcp
31                 x11-libs/libXext
32                 x11-libs/libXi )
33         amd64? (
34                 app-emulation/emul-linux-x86-gtklibs
35                 app-emulation/emul-linux-x86-sdl )"
36
37 S=${WORKDIR}
38
39 src_unpack() {
40         unpack_makeself ${PN}.run
41         unpack ./data/data.tar.gz
42
43         rm -rf data lgp_* setup*
44
45         mv bin "${T}" || die "mv"
46 }
47
48 src_install() {
49         local dir=${GAMES_PREFIX_OPT}/${PN}
50
51         exeinto "${dir}"
52         doexe "${T}"/bin/Linux/x86/* || die "doexe"
53
54         insinto "${dir}"
55         doins -r * || die "doins -r"
56
57         games_make_wrapper ${PN}-config ./ballistics_demo-config "${dir}" "${dir}"
58         games_make_wrapper ${PN} ./ballistics_demo "${dir}" "${dir}"
59         newicon icon.xpm ${PN}.xpm || die "newicon"
60         make_desktop_entry ${PN} "Ballistics (Demo)" ${PN}.xpm
61
62         prepgamesdirs
63 }