]> Pileus Git - ~andy/sunrise/blob - dev-util/ticpp/ticpp-9999.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-util / ticpp / ticpp-9999.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 ESVN_REPO_URI="http://ticpp.googlecode.com/svn/trunk/"
6 inherit subversion
7
8 MY_PV=cvs
9 DESCRIPTION="A completely new interface to TinyXML that uses MANY of the C++ strengths"
10 HOMEPAGE="http://code.google.com/p/ticpp/"
11 SRC_URI=""
12
13 LICENSE="GPL-2"
14 KEYWORDS=""
15 SLOT="0"
16 IUSE="debug doc"
17
18 DEPEND="dev-util/premake
19         doc? ( app-doc/doxygen sys-apps/sed )"
20 RDEPEND=""
21
22 S=${WORKDIR}/${PN}
23
24 src_compile() {
25         local myconf
26
27         premake --target gnu || die "creating Makefile failed"
28
29         if use !debug ; then
30                 myconf="CONFIG=Release"
31         fi
32
33         emake ${myconf} || die "emake failed"
34
35         if use doc ; then
36                 sed -i -e '/GENERATE_HTMLHELP/s:YES:NO:' dox || die "sed failed"
37                 doxygen dox || die "doxygen failed"
38         fi
39 }
40
41 src_install () {
42         insinto /usr/include/ticpp
43         doins *.h || die "installing headers failed"
44
45         if use debug ; then
46                 dolib libticppd.a || die "installing library failed"
47         else
48                 dolib libticpp.a || die "installing library failed"
49         fi
50
51         dodoc {changes,readme,tutorial_gettingStarted,tutorial_ticpp}.txt || \
52                 die "dodoc failed"
53
54         if use doc ; then
55                 dohtml -r docs/* || die "installing docs failed"
56         fi
57 }