]> Pileus Git - ~andy/sunrise/blob - dev-util/serial-io/serial-io-1.0.ebuild
dev-util/serial-io: Change dependency for serial-io, thanks to idl0r
[~andy/sunrise] / dev-util / serial-io / serial-io-1.0.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6
7 inherit qt4
8
9 DESCRIPTION="A simple program to send and receive data to and from a serial device."
10 HOMEPAGE="http://www.sourceforge.net/projects/serial-io/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND="x11-libs/qt-gui:4
19         dev-libs/libserial"
20 RDEPEND="${DEPEND}"
21
22 S="${WORKDIR}/${PN}"
23
24 src_compile() {
25         eqmake4
26         emake || die "emake failed"
27 }
28
29 src_install() {
30         emake INSTALL_ROOT="${D}" install || die "emake install failed"
31
32         dodoc TODO || die "Failed to install TODO file!"
33 }
34
35
36
37