]> Pileus Git - ~andy/sunrise/blob - dev-tex/tetex-fonts-hebrew/tetex-fonts-hebrew-0.2.ebuild
cfb0b79adf74b9a1abf8bfebc102520cd2b85271
[~andy/sunrise] / dev-tex / tetex-fonts-hebrew / tetex-fonts-hebrew-0.2.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="adds culmus fonts support for hebrew documents in LaTeX."
8 HOMEPAGE="http://ivritex.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/ivritex/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64"
14
15 RDEPEND=">=app-text/tetex-3.0"
16 DEPEND="${RDEPEND}
17                 media-fonts/culmus"
18
19 S=${WORKDIR}/${PN}
20
21 src_compile() {
22         emake CULMUSDIR=/usr/share/fonts/culmus/ || die "Compile Failed!"
23 }
24
25 src_install() {
26         #I'm using pkginstall instead of regular install to avoid sandbox
27         #violations caused by running mktexlsr and updmap
28         emake CULMUSDIR=/usr/share/fonts/culmus/ \
29                 TEXMFDIR="${D}/usr/share/texmf/" pkginstall \
30                 || die "Install Failed!"
31
32         dodoc README
33 }
34
35 pkg_postinst() {
36         mktexlsr
37         updmap-sys --enable Map=culmus.map
38 }
39
40 pkg_postrm() {
41         mktexlsr
42         updmap-sys --disable culmus.map
43 }