]> Pileus Git - ~andy/sunrise/blob - dev-tex/luximono/luximono-2004.ebuild
20e40fed8e0b625db01acf07b5c8ba049f31a7b6
[~andy/sunrise] / dev-tex / luximono / luximono-2004.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit latex-package
6
7 MY_PN="LuxiMono"
8 DESCRIPTION="LuxiMono LaTeX Type1 typewriter font"
9 SRC_URI="http://dev.gentooexperimental.org/~dreeevil/${MY_PN}-${PV}.zip"
10 HOMEPAGE="http://www.ctan.org/tex-archive/fonts/LuxiMono/"
11 LICENSE="luximono"
12
13 IUSE=""
14 SLOT="0"
15 KEYWORDS="~x86"
16
17 DEPEND="app-arch/unzip"
18 RDEPEND=">=app-text/tetex-3.0"
19
20 S=${WORKDIR}/${MY_PN}
21 PACK="luxi"
22 SUPPLIER="public"
23
24 src_unpack(){
25         unpack ${A}
26         cd "${S}"
27         unzip "${S}"/ul9.zip
28 }
29
30 src_install() {
31 #       latex-package_src_doinstall generally uses different
32 #       directories than this package expects
33 #       cd ${S}
34 #       latex-package_src_doinstall all
35
36         cd "${S}"
37         dodoc doc/fonts/luxi/* README.luximono
38
39         insinto ${TEXMF}/fonts/map/dvips/${PACK}
40         doins dvips/config/*
41
42         insinto ${TEXMF}/fonts/afm/${SUPPLIER}/${PACK}
43         doins *.afm
44
45         insinto ${TEXMF}/fonts/tfm/${SUPPLIER}/${PACK}
46         doins fonts/tfm/public/luxi/*.tfm
47
48         insinto ${TEXMF}/fonts/vf/${SUPPLIER}/${PACK}
49         doins fonts/vf/public/luxi/*.vf
50
51         insinto ${TEXMF}/fonts/type1/${SUPPLIER}/${PACK}
52         doins *.pfb
53
54         insinto ${TEXMF}/tex/latex/${PACK}
55         doins tex/latex/luxi/*
56
57 }
58
59 pkg_postinst() {
60 #       this order is intended
61         latex-package_rehash
62         updmap-sys --enable Map ul9.map
63 }
64
65 pkg_postrm() {
66         updmap-sys --disable ul9.map
67         latex-package_rehash
68 }