]> Pileus Git - ~andy/sunrise/blob - dev-tex/blahtexml/blahtexml-0.9.ebuild
623fe32375f71f68d72cf409aa04f99b015a37e8
[~andy/sunrise] / dev-tex / blahtexml / blahtexml-0.9.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="TeX-to-MathML converter"
10 HOMEPAGE="http://gva.noekeon.org/blahtexml"
11 SRC_URI="http://gva.noekeon.org/${PN}/${P}-src.tar.gz"
12
13 # Manual licensed under CCPL
14 LICENSE="BSD CCPL-Attribution-3.0 ZLIB"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE="doc"
18
19 RDEPEND="dev-libs/xerces-c"
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig
22         doc? (
23                 app-text/texlive-core
24                 dev-libs/libxslt
25                 dev-tex/latex2html )"
26
27 src_prepare() {
28         tc-export CC CXX
29         epatch "${FILESDIR}"/${P}-{Makefile,gcc-4.7}.patch
30 }
31
32 src_compile() {
33         emake blahtex{,ml}-linux
34         use doc && emake doc
35 }
36
37 src_install() {
38         dobin blahtex ${PN}
39         doman "${FILESDIR}/${PN}.1"
40         use doc && dodoc Documentation/manual.pdf
41 }