]> Pileus Git - ~andy/sunrise/blob - dev-tex/SIstyle/SIstyle-2.3.0.ebuild
457169758d6520e6a1674fc9319f347b8d7cfd83
[~andy/sunrise] / dev-tex / SIstyle / SIstyle-2.3.0.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit latex-package
6
7 DESCRIPTION="LaTeX package to typeset SI units, numbers and angles."
8 HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/SIstyle/"
9 SRC_URI="http://www.rennings.net/gentoo/distfiles/${P}.zip"
10
11 LICENSE="LPPL-1.3b"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND="app-arch/unzip"
17 RDEPEND="virtual/tetex"
18
19 S="${WORKDIR}/${PN}"
20
21 src_unpack() {
22
23         unpack "${A}"
24         cd "${S}/source/latex/SIstyle/figs"
25         unpack ./graphs_scr.zip
26
27 }
28
29 src_install() {
30         cd "${S}/tex/latex/SIstyle"
31         latex-package_src_install
32         cd "${S}/doc/latex/SIstyle"
33         latex-package_src_install
34
35         cd "${S}/source/latex/SIstyle"
36         insinto "${TEXMF}/source/latex/SIstyle"
37         doins sistyle.dtx sistyle.ins
38         doins figs/fig{1,2}.*ps
39         cd figs/graphs_scr
40         insinto "${TEXMF}/source/latex/SIstyle/graphs_src"
41         doins *.mp MPfig.bat readme_figs.txt *.m
42 }