]> Pileus Git - ~andy/sunrise/blob - dev-tcltk/tkdnd/tkdnd-1.0_alpha2.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-tcltk / tkdnd / tkdnd-1.0_alpha2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 MY_P=${P/_alpha/a}
8
9 DESCRIPTION="TkDnD is an extension that adds native drag & drop capabilities to the tk toolkit."
10 HOMEPAGE="http://www.iit.demokritos.gr/~petasis/Tcl/"
11 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17 RESTRICT="test"
18
19 DEPEND=">=dev-lang/tcl-8.4
20         >=dev-lang/tk-8.4"
21 RDEPEND=${DEPEND}
22
23 S=${WORKDIR}/${MY_P}/unix/
24
25 src_unpack() {
26         unpack ${A}
27         # Patch to avoid a sandbox issue
28         epatch "${FILESDIR}/${P}-destdir-issue.diff"
29 }
30
31 src_install() {
32         emake install DESTDIR="${D}" || die "emake install failed"
33         dodoc doc/* Readme.txt || die
34 }