]> Pileus Git - ~andy/sunrise/blob - dev-ruby/dnsruby/dnsruby-1.52.ebuild
dev-ruby/dnsruby: Version bump
[~andy/sunrise] / dev-ruby / dnsruby / dnsruby-1.52.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 USE_RUBY="ruby18"
8
9 RUBY_FAKEGEM_TASK_TEST=""
10
11 RUBY_FAKEGEM_DOCDIR="html"
12 RUBY_FAKEGEM_EXTRADOC="DNSSEC EXAMPLES README"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="A pure Ruby DNS client library"
17 HOMEPAGE="http://rubyforge.org/projects/dnsruby/"
18
19 KEYWORDS="~amd64 ~x86"
20 LICENSE="Apache-2.0"
21 SLOT="0"
22 IUSE=""
23
24 each_ruby_test() {
25         # only run offline tests
26         #${RUBY} -I lib test/ts_dnsruby.rb || die "test failed"
27         ${RUBY} -I lib test/ts_offline.rb || die "test failed"
28 }