]> Pileus Git - ~andy/sunrise/blob - dev-python/yenc/yenc-0.4.0.ebuild
net-nntp/sabnzbd: Version bump for SABnzbd
[~andy/sunrise] / dev-python / yenc / yenc-0.4.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 PYTHON_DEPEND="2:2.6"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="2.5 3.*"
10
11 inherit distutils python
12
13 DESCRIPTION="A fairly simple module, it provide only raw yEnc encoding/decoding"
14 HOMEPAGE="http://www.golug.it/yenc.html"
15 SRC_URI="http://www.golug.it/pub/${PN}/${P}.tar.gz"
16
17 LICENSE="LGPL-2.1"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 IUSE=""
21
22 src_install() {
23         distutils_src_install
24
25         dodoc doc/yenc-draft.1.3.txt
26 }
27
28 src_test() {
29         testing() {
30                 PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" \
31                         "$(PYTHON)" "test/test.py"
32         }
33         python_execute_function testing
34 }