]> Pileus Git - ~andy/sunrise/blob - dev-python/yenc/yenc-0.4.0-r1.ebuild
dev-python/yenc: Add a patch and rewrite with python-distutils-ng, thanks to Tommy[D]
[~andy/sunrise] / dev-python / yenc / yenc-0.4.0-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 PYTHON_COMPAT="python2_6 python2_7"
8
9 inherit eutils python-distutils-ng
10
11 DESCRIPTION="A fairly simple module, it provide only raw yEnc encoding/decoding"
12 HOMEPAGE="http://www.golug.it/yenc.html"
13 SRC_URI="http://www.golug.it/pub/${PN}/${P}.tar.gz"
14
15 LICENSE="LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 IUSE=""
19
20 src_prepare(){
21         # Remove forced CFLAG on setup.py
22         epatch "${FILESDIR}/${PN}-remove-cflags.patch"
23 }
24
25 python_test() {
26         PYTHONPATH="$(ls -d build/lib.*)" \
27                 "${PYTHON}" test/test.py || die "Test failed."
28 }
29
30 src_install() {
31         python-distutils-ng_src_install
32
33         dodoc doc/${PN}-draft.1.3.txt
34 }